Details


Author Topic: HELP!!!!!!!! LOST OF POWER ON LOW REVS (2008 LEGACY WAGON N/A)  (Read 130 times)

0 Members and 1 Guest are viewing this topic.

Offline SON OF A SUBBIE

  • New Member
  • *
  • Posts: 19
  • Gender: Male
    • View Profile
Greetings,
I have a 2008 Legacy B Sport.
I am having really hard starts, misfires and no power on low revs.
changes the MAF sensor and to no avail. Help please. [wave] [wallbash] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help] [help]
You only sneeze when you eating my dust.

Offline Jimpro

  • Moderator
  • Senior Member
  • *****
  • Posts: 858
  • Gender: Male
  • Subaru Tuner
    • View Profile
Re: HELP!!!!!!!! LOST OF POWER ON LOW REVS (2008 LEGACY WAGON N/A)
« Reply #1 on: April 4, 2019, 08:38:34 AM »
Have you checked the following:

- Fuel pump and Intank Filter
- Catalytic Converter
- Compression Test

One or more of the above could also be contributing to you problem.
JIM Enterprises Limited Tel: 876-369-8986 (D) www.facebook.com/srsperformance Insta: @srsperformanceja

Offline SON OF A SUBBIE

  • New Member
  • *
  • Posts: 19
  • Gender: Male
    • View Profile
Re: HELP!!!!!!!! LOST OF POWER ON LOW REVS (2008 LEGACY WAGON N/A)
« Reply #2 on: April 4, 2019, 07:12:13 PM »
Doing a fuel pump check on the weekend. also noticed a code p0171
Have you checked the following:

- Fuel pump and Intank Filter
- Catalytic Converter
- Compression Test

One or more of the above could also be contributing to you problem.
You only sneeze when you eating my dust.